Missing firewall exceptions
Symptoms:
- SQL connectivity errors appear in logs (for example: "A network-related or instance-specific error occurred while establishing a connection to SQL Server").
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The user interface portal fails to load or the Web UI displays error messages in any remote (client-side) browsers but loads successfully on the web server.
Possible causes:
- The web server on which the Itron Platform is installed and the database server on which Itron Identity database is installed were deployed on different hosts, but inbound traffic on the database port (which by default is port 1433) is not allowed.
- The non-standard HTTP(S) ports that are used (such as 20800 and 10800) have not been enabled on the web server's firewall.
Resolution:
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Create an Inbound Port Rule. Refer to the following Microsoft article:
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Configure the Windows Firewall to Allow SQL Server Access. Refer to the following Microsoft article: